Vscode zig extension has stopped working for me

hi. I have installed zig 0.11.0 and zig dev using ZVM on my arch system. and i have installed official zig extension on vscode. vscode-zig was working properly until today but it stopped working(editor autocomplete and semantic highlighting doesn’t work anymore). I have tried set the zig and zls path manually but it didn’t solve my problem.

You might be affected by The extension no longer automatically starts ZLS · Issue #176 · ziglang/vscode-zig · GitHub

A bug in version 0.5.3 of the extension prevents ZLS from starting automatically. You can either downgrade to 0.5.2 for the tme being, or run “Zig Language Server: Start / Restart Server” from the command palette to manually start ZLS.

1 Like

Welcome @markedfive,

While using 0.11.0 zls I had to start manually the language server and restart it when crashing (when no completion is available, no proper highlight, no outline, etc).
The command is Ctrl+Shift-P “Zig Language Server: Start / Restart Server”

I switched to 0.12.0-dev master build, vscode plugin downloaded the latest language server for me, and all the problems gone.

2 Likes

Thank you! it solved my problem!